Friday, January 5, 2018

How to set up the Icom 7300 for Digital Modes with FLDIGI in Windows




I have found my Icom IC-7300 to be an excellent radio for digital modes.  It was about a week-long learning curve for me to figure out how to set it up and use it to make digital QSOs.  It seemed like several ops had partial instructions, but often forgot important information, or assumed I knew it . I was tearing my hair out trying to get a step-by-step guide that had pretty much everything in one place.  Hopefully, this is it.

I wanted to pass along a few things that might help you speed up your learning curve.  I don't consider myself an expert, but I am now making QSO's with no major troubles.

Here are my suggestions:

1.  Before plugging anything in, you will need Icom's driver for your computer.  After installing it, I suggest a restart of your Windows machine.  Here is that driver (and check for the newest, as Windows 10 has caused issues with updates and older drivers):
https://www.icom.co.jp/world/support/download/firm/IC-7600/usb1_30/

2.  You'll need a USB cable to go from the Icom 7300 to your computer.  I used an old printer cable, as the Icom end of that cable fit that style.  Don't plug it into your computer until you have completed step 1.

3.  Download and install the FLDIGI software to your computer. It's free, and can be found a few places.  Here is one:  https://sourceforge.net/projects/fldigi/

4.  I followed someone else's Youtube video about set-up, and found his settings to be pretty good.  Here is what I changed settings to on the Icom 7300:

a.  Hit MENU
b.  Touch SET
c.  Touch CONNECTORS
d.  Set all of the menu settings under CONNECTORS to the following:


  1. ACC/USB Output Select:  AF
  2. ACC/USB AF Output Level:  96%
  3. ACC/USB AF SQL:  OFF (Open)
  4. ACC/USB AF BEEP/Speech Output: OFF
  5. ACC/USB IF Output Level: 50%
  6. ACC MOD Level: 50%
  7. USB MOD Level: 85%
  8. DATA OFF MOD:  MIC
  9. DATA MOD:  USB
  10. EXTERNAL KEYPAD (I didn't change these, but all under that submenu are off)
  11. CIV (touch it once -- these settings are important for Ham Radio Deluxe, but I don't think for FLDIGI -- will add what I have, currently)
    1. CI-V Baud Rate: AUTO
    2. CI-V Address:  94h
    3. CI-V Transceive OFF
    4. CI-V USB REMOTE Trans Addr:  00h
    5. CI-V Output (for ANT): ON
    6. CI-V USB Port:  Link to [Remote]
    7. CI-V USB Baud Rate: 19200 (greyed-out)
    8. CI-V USB Echo Back:  On
  12. USB Serial Function:  OFF
  13. RTTY Decode Baud Rate: 19200 (this is greyed-out)
  14. USB Send:  RTS
  15. USB Keying (CW) DTR
  16. USB Keying (RTTY) DTR
  17. Back out of the menu, then press the MULTI dial, and turn your COMP off.  It must be OFF in digital modes, or you will splatter to high heaven, and anger other hams.
  18. Set your RF POWER level to 50%, or below, for most digital work (you may want your monitor off, or on very low, as well.
  19. Put your Icom 7300 in USB-D mode.  This is the default for most digital modes.  To do this, touch the blue USB (or LSB) icon on your 7300 screen.  Choose DATA.  You might need to toggle from LSB into USB, and then DATA, until you reach USB-D.  
  20. If you haven't done so, plug the USB cable into your radio, and the computer (Icom USB software must be installed first, as noted in step 1).




IN WINDOWS I run Windows 10, and here are the windows sound card settings I use.  It may seem extreme to have a very high output level on the Icom 7300, and a very low input level on the computer sound card, but I have read this is the best way to do it.  It works, in any case.  If anyone has different opinions, I'd love to hear them, so post below.


e.  On your Windows 10 computer, navigate to SOUND (click Windows logo at lower left of screen, then type "sound".  Choose SOUND Control Panel.

f.  Under the Playback tab, double-click Speakers (#) USB Audio CODEC.
g.  Click the "levels" tab, an set Speakers to 5 (yes, just 5)
h.  Click on the "Enhancements" tab, and make sure every checkbox is empty (no enhancements)
i.  Click on the "Advanced" tab, and set for 16 bit, 44100 Hz (CD Quality).  Also add a check to each of the two checkboxes under Exclusive mode.
j.  Click on the "Spatial Sound" tab, and make sure it is set to "None."


FLDIGI:

Run FLDIGI.  Tom Leung has a nice series of FLDIGI videos on Youtube, which explain it all well, so I will just link you to them, here, beginning with video 2 (video 1 is just download/install):


Follow Tom's videos and settings.  That should get you going!  Also, please note that the Icom settings xml file is here, and will help a lot! Tom mentions where to install this into FLDIGI. Use it:


http://www.w1hkj.com/xmls/icom/IC-7300.xml

After Installation start fldigi and go to
Configure -> Rig ->RigCat
Select the downloaded xml file. Under Device select “SLAB_USBtoUART” (driver name).
Set Baud rate to 19200.
Tick CAT command for PTT
Audio Port: Audio USB Audio CODEC
The “sweet spot” for the IC-7300 in data mode is 1500 Hz.
Configure -> Misc -> Sweet Spot PSK et al.: 1500

(thanks from here: https://klsin.bpmsg.com/ic-7300-and-fldigi/ )

A few more notes about FLDIGI:

1.  You might, on occasion, find the 7300 and FLDIGI "flake-out" and do some weird things.  For one, on restart, the 7300 may transmit.  I find it best to turn off the 7300 during a restart, and not turn it back on, until Windows has finished its restart process.  Another bug I have noticed is that a hiccup happens somewhere between FLDIGI, the 7300, and Windows, and it won't leave TX.  Often, I have observed this happening when I decide to start a TX, then click around in other windows and do other things (like internet surf).  I'm not sure why, but it's an issue at least one other user mentioned.  Another bug... I will sometimes open FLDIGI, or come back to FLDIGI after it's been running in the background, and find the frequency is way off -- usually showing something like 108702 on the dial.  I usually find that completely closing the program, or a restart of Windows, solves this issue.  Lastly, I find that I catch FLDIGI splattering somewhat around my signal (just partially), and it is visible in the waterfall.  What is normally a straight PSK line will develop wavy blue bulges around it, on my 7300's TX waterfall, which I can see when the waterfall is "centered" on the frequency.  I find restarting FLDIGI, and turning on/off the 7300 fixes this.

FLDIGI is a free program, and although I'm not sure it is to blame, I have found these occasional hiccups to be something I work around.
2.  The #1 mistake that I make is that I forget to turn of the voice compression on my 7300.  This splatters all over the digital frequencies, and I have to remember to turn it off (because I often switch to SSB for voice work).

3.  The #3 mistake I make is that I forget to set the computer into USB-D, and the FLDIGI software to USB-D, for digital work.  For some reason, FLDIGI likes to toggle that pulldown into something else, like LSB-D.  You only want USB-D on that pulldown (at least, from what I know) or most people won't understand your digital signal.

4.  Where you are transmitting on the waterfall DOES make a difference.  I try to stay away from the edges of the waterfall, because those areas seem to distort sound -- probably due to how the Twin PBT filtering works.  I try to stay in the middle 1/3 of the blue waterfall, when transmitting or receiving, for best results.

5.  Make sure the RxID and TxID tabs are highlighted, at upper-right, when you run FLDIGI.  These are important when using Olivia and other modes that are difficult to guess.  They aid other hams in figuring out what you are transmitting, and you will get more contacts.


Watch Tom's videos, above, and good luck!  If you have any suggestions about what I've written here, please tell me.  I'm no expert, but it's working well for me!

1 comment: